The Computer Love

Cómo configurar la conexión Wifi del HDD Easy Player Media Recording HDMI

Posted in configuración, hardware, instalaciones, multimedia by EdV on J diciembre 2008

El cacharro en cuestión

Introducción

No hace mucho he adquirido un disco duro multimedia, en concreto un Best Buy Easy Player Media Recording HDMI de 750 Gb. Es un sistema basado en el chip RTD1261 que se monta en bastantes aparatos. El más conocido es el Emtec MovieCube  R700. Éste y el mío son hermanos gemelos/clónicos.

El aparato tiene sus virtudes:

  • Una alta capacidad
  • Permite grabar desde cualquier fuente y editar facilmente desde el propio reproductor.
  • La reproducción de vídeos y mp3 es bastante buena.
  • Tiene conexiones USB host (para leer desde otros dispositivos, por ejemplo un pendrive)
  • Posee conexión ethernet y wifi (opcional) lo que permite ver en streaming contenidos alojados en otros dispositivos de una red. Cuenta con NAS lo que además nos permite copiar/mover  a través de esa red (evitando así ir con el reproductor de un sitio a otro para transferir archivos)
  • Permite subtítulos y tiene bastantes opciones para los mismos (cambiar tamaño, color, posición)

Pero también tiene sus defectos:

  • Es ruidoso por el uso permanente del ventilador y, a veces, por el acceso al disco duro.
  • Tiene un problema importante con las interferencias (casi cualquier mando lo enciende)
  • La navegación del menú es lenta (especialmente desesperante al navegar entre vídeos, ya que los previsualiza.
  • Los subtítulos no tienen bordes ni un fondo de color, lo que crea muchos problemas a la hora de verlos. Siempre hay algún color que se mezcla con el color de la fuente dificultando su lectura.
  • Best Buy no parece cuidar mucho a sus clientes. Por ahora no ha habido ninguna actualización del firmware, mientras que Emtec sí que ha realizado varias. La disponibilidad de accesorios también es menor. por ejemplo el adaptador Wifi he tenido que comprarlo a través de la tienda online porque no lo encontraba en ningún sitio. Es más, hasta hace muy poco ni siquiera estaba disponible en la propia tienda de Best Buy.

El tema de los subtítulos me fastidia bastante porque veo bastantes series y películas en versión original. Desconozco si el Emtec arregla este fallo del Best Buy y si los firmwares del primero son compatibles con el segundo.

Configurar la conexión Wifi


Hace un par de días que recibí el adaptador Wifi USB; por supuesto no funcionaba y me tuve que poner a investigar como lograr que cumpliese su cometido. Hay bastante información en foros (siempre referida al MovieCube) pero voy a recopilarla aquí para facilitar las cosas:

Consideraciones:

De redes tengo poca idea, así que estos pasos son los que funcionaron en el mi caso concreto que son: Conexión con Telefónica, usando una clave WEP en ASCII alfanumérica (ver ejemplo debajo) con un router Comtrend CT-5361. Por tanto, con otros elementos/componentes los pasos a dar pueden ser distintos.

En el PC:

  • Activa el NETBIOS de TCP/IP del PC
  • Activar una cuenta de invitado
  • Compartir las carpetas que deseamos ver desde el reproductor y conceder permisos de acceso a “todos” o “invitado”

En el reproductor:

  1. Conectar el adaptador wifi con el reproductor encendido. En pantalla aparecerá un mensaje indicando que ha sido enchufado.
  2. Setup > Red
  3. Deshabilitamos la conexión ethernet si la tuviesemos configurada anteriormente. Entramos en ‘Configuración LAN‘ y pulsamos la opción cancelar.
  4. Entramos en ‘Configuración Wifi‘.
  5. Elegimos ‘Modificar‘.
  6. Modo de conexión:  ‘Infraestructura (AP)
  7. Obtener SSID: Nos mostrará varias opciones:
    1. En primer lugar las conexiones inalámbricas disponibles. En mi caso solo capto una. Supongo que si están disponibles más aparecerçán también listadas.
    2. Automático: El sistema busca y muestra las conexiones disponibles.
    3. Manual: Seremos nosotros los que tengamos que escribir el SSID de nuestra conexión.
  8. Confirmar SSID.
  9. Seguridad de red inalámbrica: Este apartado es importante y es el que más quebraderos de cabeza me ha dado. Las opciones disponibles son:
    1. Abrir sistema: Es una mala traducción; en realidad tendría que poner ‘Sistema abierto‘, es decir sin contraseña. Lo usaremos si es nuestro caso.
    2. Clave compartida (WEP): Es la que utiliza mi router. Al pulsar se nos muestra un teclado con los números y las letras de la a a la f (en minúscula). Esto es debido a que debemos introducir la clave en formato hexadecimal. En el caso de Telefónica la clave vienen en formato ASCII por lo que hay que realizar una conversión. Yo he usado un conversor online. Introducimos la clave WEP en ASCII  (C0030ADE912EA en este ejemplo, respetando las mayúsculas/minúsculas), seleccionamos ASCII to Hex en el desplegable y pulsamos ‘Ejecutar codificación‘ y obtendremos una imagen como la de abajo, en la que se muestra el código en hexadecimal (43 30 etc) que es el que tendremos que usar en el reproductor, eliminando las espacios en blanco entre las parejas de números.
      Conversión de ASCII a hexadecimal
    3. Clave WPA: Tendrás que introducirla si es la que usas.
  10. Después de este paso se realiza un test, tras el cual podemos usar la red Wifi.
Anuncios

Más de los putos drivers

Posted in hardware, internet, problemas, vista, windows by EdV on J noviembre 2008

En la anterior entrada comentaba el problema de los drivers y menciona algunas de las dificultades que me he encontrado, sin embargo el problema más gordo con el que me he enfrentado hasta ahora ha tenido que ver con la tarjeta de red y también tenía que ver con un driver. Esta es la crónica:

Al poco de tener instalado el sistema comenzaron las pantallas azules de la muerte (BSOD que dicen los angloparlantes). No tenía idea de a qué podian deberse. Buscando encontré esta interesante guía en la explican como usar winDBG para averiguar qué falla. A mí me dió como resultado que el driver responsable era netr6164.sys, que al parecer, es el driver del chip de mi tarjeta de red (una Conceptronic 54g Wireless PCI Card con chip c54Ri (un ralink RT61), ya me dió problemas con Ubuntu). Al principio me extraño porque me había bajado el driver para Vista de la página oficial del fabricante. Sin embargo en Conceptronic son unos chapuzas y el driver que suministran es bastante viejo (v2.0.3.0) mientras que el fabricante de los chips (Ralink) hace mucho tiempo que ofrece una versión actualizada (v2.1.0.0). La solución la encontré aquí (en francés) el driver concreto es el PCI/mPCI/CB(RT256x/RT266x) .

Todo parecía ir bien hasta que le añadí al ordenador 4 GB de RAM, para hacer un total de 6 GB. Los módulos eran dos de 2 GB DDR2 800 Kingstom Valueram y están en perfectas condiciones (memtest de varias horas sin problemas).  El problema residia en que al usar una aplicación P2P, fundamentalmente cualquiera que use el protocolo bittorrent, el ordenador se colgaba, pero a lo bestia: no respondía ni al ratón ni al teclado, así que tocaba hacer un reset por hardware (dándole al botón)

Usando una conexión por cable no aparecía el problema, así que éste residia en la tarjeta WIFI. Investigando por la red, descubro que hay muchos más casos como el mío: Windows Vista x64 + una cantidad alta de RAM + Tarjeta Wifi con chipset Ralink = ordenador congelado.

A partir de este momento empiezo a instalar drivers compatibles de todo tipo y ninguno funciona. Le escribo a Ralink y ni me responden. Conceptronic me contesta, aunque de manera errática:

  • El servicio técnico en inglés me manda unos drivers de 64bits que no funcionan porque son para XP. les vuelvo a explicar el problema y finalmente me dicen que es cosa de Ralink y que se han puesto en contacto con ellos.
  • El servicio técnico en español me dice desde el principio que es un problema de drivers y que se lo han enviado a Ralink.

Tarjeta PCI wifi TL-WN651G

Como no tengo ninguna esperanza en que Ralink solucione este fallo de manera rápida me he comprado una tarjeta PCI wifi nueva, por supuesto sin chip Ralink. Me he decidido por una con chipset Atheros (AR5005GS), que está bastante más actualizada y de la que hay multitud de marcas que los montan. En concreto una TP-Link WN651G.

Windows Vista trae un driver propio para esta tarjeta, así que simplemente pinchándola empieza a funcionar. El driver que trae, que es el mismo que está disponible en su web, es bastante antiguo y no está firmado (y Vista para eso es bastante estricto) y es bastante inestable, así que finalmente me he decidido por la versión más reciente que he encontrado (v.7.6.0.126) en la estupenda web atheros.cz. Por ahora ningún problema, va perfecta, para manda huevos que tenga que ser uno el que se busque las habichuelas (drivers) para conseguir que todo funcione a la perfección.