The Computer Love

Más de los putos drivers

Posted in hardware, internet, problemas, vista, windows by EdV on J noviembre 2008

En la anterior entrada comentaba el problema de los drivers y menciona algunas de las dificultades que me he encontrado, sin embargo el problema más gordo con el que me he enfrentado hasta ahora ha tenido que ver con la tarjeta de red y también tenía que ver con un driver. Esta es la crónica:

Al poco de tener instalado el sistema comenzaron las pantallas azules de la muerte (BSOD que dicen los angloparlantes). No tenía idea de a qué podian deberse. Buscando encontré esta interesante guía en la explican como usar winDBG para averiguar qué falla. A mí me dió como resultado que el driver responsable era netr6164.sys, que al parecer, es el driver del chip de mi tarjeta de red (una Conceptronic 54g Wireless PCI Card con chip c54Ri (un ralink RT61), ya me dió problemas con Ubuntu). Al principio me extraño porque me había bajado el driver para Vista de la página oficial del fabricante. Sin embargo en Conceptronic son unos chapuzas y el driver que suministran es bastante viejo (v2.0.3.0) mientras que el fabricante de los chips (Ralink) hace mucho tiempo que ofrece una versión actualizada (v2.1.0.0). La solución la encontré aquí (en francés) el driver concreto es el PCI/mPCI/CB(RT256x/RT266x) .

Todo parecía ir bien hasta que le añadí al ordenador 4 GB de RAM, para hacer un total de 6 GB. Los módulos eran dos de 2 GB DDR2 800 Kingstom Valueram y están en perfectas condiciones (memtest de varias horas sin problemas).  El problema residia en que al usar una aplicación P2P, fundamentalmente cualquiera que use el protocolo bittorrent, el ordenador se colgaba, pero a lo bestia: no respondía ni al ratón ni al teclado, así que tocaba hacer un reset por hardware (dándole al botón)

Usando una conexión por cable no aparecía el problema, así que éste residia en la tarjeta WIFI. Investigando por la red, descubro que hay muchos más casos como el mío: Windows Vista x64 + una cantidad alta de RAM + Tarjeta Wifi con chipset Ralink = ordenador congelado.

A partir de este momento empiezo a instalar drivers compatibles de todo tipo y ninguno funciona. Le escribo a Ralink y ni me responden. Conceptronic me contesta, aunque de manera errática:

  • El servicio técnico en inglés me manda unos drivers de 64bits que no funcionan porque son para XP. les vuelvo a explicar el problema y finalmente me dicen que es cosa de Ralink y que se han puesto en contacto con ellos.
  • El servicio técnico en español me dice desde el principio que es un problema de drivers y que se lo han enviado a Ralink.

Tarjeta PCI wifi TL-WN651G

Como no tengo ninguna esperanza en que Ralink solucione este fallo de manera rápida me he comprado una tarjeta PCI wifi nueva, por supuesto sin chip Ralink. Me he decidido por una con chipset Atheros (AR5005GS), que está bastante más actualizada y de la que hay multitud de marcas que los montan. En concreto una TP-Link WN651G.

Windows Vista trae un driver propio para esta tarjeta, así que simplemente pinchándola empieza a funcionar. El driver que trae, que es el mismo que está disponible en su web, es bastante antiguo y no está firmado (y Vista para eso es bastante estricto) y es bastante inestable, así que finalmente me he decidido por la versión más reciente que he encontrado (v.7.6.0.126) en la estupenda web atheros.cz. Por ahora ningún problema, va perfecta, para manda huevos que tenga que ser uno el que se busque las habichuelas (drivers) para conseguir que todo funcione a la perfección.

Anuncios

En busca del driver perdido

Posted in configuración, instalaciones, problemas, vista, windows by EdV on J noviembre 2008

Lo primero que hice fue instalar los drivers para la tarjeta gráfica, ya que el índice de “experiencia de windows” me daba un valor de 1. Con ellos el índice global se quedó en 5.5, que no está mal. El tema de los drivers es quizá el más peliagudo:

  • La versión de los drivers de mi tarjeta gráfica nVidia para Vista, no trae nview. Éste es un programa que permite configurar distintos aspectos del escritorio (uso de varios monitores, por ejemplo) así que no queda más remedio que buscarse una alternativa: UltraMon, que no es tan completo como nview pero cubre mis necesidades (uso de fondos de escritorio distintos para cada monitor, mover ventanas entre ellos).
  • Mi impresora es una HP photosmart P1000, de serie media y que se puso a la venta en 2002 -creo-. No tiene ni tendrá drivers para Windows Vista porque es demasiado “vieja”. Solución: usar los drivers de la HP 935 que son compatibles y funcionan bien.
  • Mi webcam es una creative Webcam NX (modelo PD1110), también antigua. Por supuesto no tiene driver ni alternativa que yo sepa. Menos mal que casi nunca la usaba. El caso es que es difícil -casi imposible- encontrar los drivers incluso para Windows XP. Creative se ha desentendido completamente de este producto. Si alguien esta interesado: los drivers de la webcam NX PD1110 de Creative pueden descargarse desde aquí (windows XP).

Como pasa con Linux, es una vergüenza que compañías de la importancia de nVidia, HP o Creative no hagan drivers para productos que, pese a su antigüedad, son perfectamente utilizables.

Instalación y primeras impresiones

Posted in instalaciones, opinión, vista, windows by EdV on J noviembre 2008

La versión instalada ha sido la Ultimate de 64 Bits de Vista (con SP1). Que haya sido la Ultimate no ha sido por nada especial, sino simplemente porque era la única que encontré para descargar. Sí quería sin embargo que fuese de 64 bits, para ver si existe una diferencia real y notable entre un SO de 32 y otro de 64.

Se instaló en un disco SATA II de 250 GB con formateo al instalar. La instalación y activación no dio problemas de ningún tipo.

El aspecto estético es algo muy personal. A mí Windows Vista me agrada, aunque prefiero la apariencia de Ubuntu. Aero no está mal, pero Compiz le da mil vueltas en todos los sentidos. He desactivado la barra lateral porque no le veo mucho uso. El cambiador de ventanas me parece una chorrada y encuentro el típico ALT + TAB más rápido y eficaz. Los iconos me causan disparidad de opiniones, unos me gustan y otros los detesto, así que los estoy sustituyendo (ya explicaré el procedimiento). Los fondos de escritorio tampoco me gustan mucho así que estoy usando los aqua blue de mac os.

Escritorio uno

El navegador de windows me parece una gran mejora. El UAC es efectivamente un coñazo. Desinstalado.

En cuanto al rendimiento, no he notado una bajada respecto a Windows XP (si bien es cierto que tengo menos programas instalados). Todo va bastante fluido. Y al ser un sistema de 64bits puede meterle hasta 8 gigas de RAM, lo máximo que soporta mi placa base. Imagino que con 6-8 gigas irá más fluido aún.

Como ves, en general, me ha causado una buena impresión, tanta que lo que pensaba que iba a ser algo temporal probablemente se convierta en algo definitivo.

Return

Posted in el blog by EdV on J octubre 2008

Dejé aparcado el blog porque dejé de usar Ubuntu. Cambié de ordenador y cuando quise instalar de nuevo Ubuntu tuve un problema gordo que no he sido capaz de solucionar: Mi nuevo ordenador usa 3 discos duros, dos de ellos SATA y uno IDE, Ubuntu se instaló sin problemas pero no así GRUB, que bien no se mostraba o bien daba un error. Después de mirar en los foros e intentar distintas soluciones (que no lo eran) me dí por vencido. Así que volví en exclusiva a Windows XP, esta vez con SP3.

Hace poco decidí formatear el sistema y antes de volver a instarlo todo, pensé en probar Vista y comprobar en mis propias carnes lo desastroso que es. Además opté por la versión de 64 bits, proque ya puestos a experimentar, mejor hacerlo a lo bestia. Sorprendentemente no me ha parecido tan malo y ahora es el único que tengo instalado. Quiero seguir probándolo y este blog dejará constancia de mis pasos.

Como este blog (que antes se llamaba el amigo informático y estaba en ubuntulab.wordpress.com) trataba de documentar los problemas y soluciones que me iba encontrando instalando y usando un sistema operativo (Ubuntu en aquel momento) he pensado en relanzarlo para registrar mi experiencia Vista (y otras cuestiones informáticas). No tenía mucho sentido que tuviese una URL que hacía referencia a Ubuntu, así que borré el blog anterior y he creado este con un nombre y dirección más neutral (thecomputerlove.wordpress.com) y he importado los contenidos del anterior.

En breve comienzo.

Eliminar capas flotantes de publicidad en Firefox

Posted in configuración, internet, software, trucos by EdV on J junio 2007

[Nota: este artículo fue publicado originalmente en mi otro blog, pero lo he trasladado a este por tener una temática más acorde]

Una de las cosas más molestas de ciertas web -relacionadas con el vicio- es la publicidad que aparece en forma de ventana; me refiero a capas DIV que simulan ser los típicas ventanas emergentes o popup. Para que quede más claro:

Es un coñazo tener que ir cerrándolas cada vez que cambias de página. Por no mencionar que no son más que una estafa (valientes hijosdeputa los webmasters que usan esta publicidad a sabiendas). Para eliminarla necesitamos (dando por supuesto que usamos Firefox) la extensión Adblockplus. Esta extensión es de sobra conocida y es muy fácil de usar, sober todo con imágenes estáticas. Sin embargo cuando la publicidad está en una capa la cosa se complica un poco. El procedimiento a seguir para librarnos de ella es este:

  1. Se mira el código fuente de la página web en la que aparece la capa de publicidad. Esto se hace de alguna de estas formas:
    • Botón secundario/derecho del ratón > Ver código fuente de la página
    • Editar > Ver código fuente de la página
    • CTRL + U
  2. Nos fijamos en una parte similar a esta: (las negritas son mías para destacar lo que nos interesa)
  3. layer += '<'+'div id="postit" style="position:absolute;width:611px;height: 400px;z-index:1;left:200px;top: 150px; overflow: hidden; background-color: #fff;border:1px solid #555;border-bottom:2px solid #555;margin:0;padding:0">';

    Este trozo de código nos informa de que el nombre/identificador de la capa de publicidad es “postit” (y suele ser así en la mayoría de las páginas), que es el dato que nos interesa.

  4. Abrimos las preferencias de Adblockplus y añadimos la siguiente regla: #div(nombre-de-la-capa), en nuestro caso #div(postit), aplicamos y aceptamos. ¡Listo! La próxima vez que visitemos la página no aparecerá la publicidad.

Más instalaciones

Posted in configuración, instalaciones, linux, ubuntu by EdV on J junio 2007

Más cosas que he instalado:

Bootup manager: Para gestionar lo que se carga al inicio de la sesión. Está en los repositorios.StartUp manager: Para configurar GRUB de manera muy sencilla. [via Mundogeek, para variar)  Hay que descargar el paquete correspondiente de esta página, ya que no se encuentra en los repositorios.

Programas de grabación: Gnomebaker y K3b. La verdad es que la grabación de CDs y DVDs está siendo problemática. Ya me han fallado 2 o 3 CDs/DVDs de 5 o 6 que he grabado, lo que no es normal (todos marca Verbatim) En WXP no me sucede debe haber algo que no funciona bien.

A través de Automatix he instalado:

  • AMSN, aunque no me funciona porque falla la descarga e instalación del módulo TLS
  • Skype
  • Deluge (muy lento en comparación con utorrent en Windows. Los puertos usados son los mismo y están abiertos.
  • aMule
  • Exile, Listen y VLC: Aunque ninguno me parece mejor que amarok
  • Lectura y escritura FAT32 y NTFS
  • CTRL-ALT-DEL pero no funciona
  • Google Earth y Picasa
  • Archiving tools y Sbackup
  • Wine (aunque aún no sé usarlo)
  • Opera

Lo que me gusta de Ubuntu y lo que no

Posted in linux, opinión, ubuntu by EdV on J mayo 2007

Después de estar unas semanas trasteando con el sistema ya puedo dar mi opinión de neófito sobre Ubuntu Feisty Fawn. Dejo al margen las cuestiones de tipo ético que hay detrás del software libre, no porque no me importen, sino porque prefiero centrarme en la experiencia diaria:

Lo que me gusta:

  • El sistema es estable, responde bien, no se “atasca” con frecuencia. En mi Windows XP todo parece ir un poco más lento y las aplicaciones tardan más en responder, aunque hay que tener en cuenta que tengo más servicios corriendo en Windows que en Linux.
  • Beryl: Es una maravilla visual que va sobradísima. La instalación es sencillísima y la pude hacer desde Synaptic. Las posibilidades de personalización son enormes.
  • La organización del menú, que es perfectamente clara: Aplicaciones, lugares y Sistema. El menú de Windows es bastante más confuso, o por lo menos, tiende a serlo. Eso sí, los menues de Sistema podrían estar algo más claros.
  • La instalación de aplicaciones: por ejemplo instalar un adaptador USB de Bluetooth fue infinitamente más fácil que en Windows, y su funcionamiento habitual más cómodo. El sistema de actualización del sistema es fantástico: automático, rápido, transparente.
  • Amarok! Que es una delicia como reproductor y organizador de música. Me da igual tener que cargar KDE, para mí no hay otro igual. Una aplicación que casi justifica el cambio de SO, o, como dicen los capullos, una killer app. Me rio de ese pedazo de mierda que es iTunes (y de todos sus imitadores, que en Linux también los hay)

Lo que no me gusta:

  • Los juegos, o su ausencia. Y no me refiero a las 4 en raya, al tetris y otros juegos menores de mesa. Me gustaría jugar al Railroad Tycoon 2, Stalker, SimCity 4, etc. Ya sé que está Wine, pero mientras aprendo a usarlo echo de menos poder jugar sin tenr que reiniciar el ordenador. Además me da que no es lo mismo, y más cuando yo uso la versión Amd64.
  • La configuración de algunos aspectos, por ejemplo, la resolución y frecuencia de actualización de pantalla requieren usar la consola y editar ficheros  de texto. No es para tanto, pero cansa.
  • Software fotográfico: Ver en el explorador miniaturas de los ficheros RAW, ausencia de Photoshop (aunque the Gimp esté muy bien) y otros programas a los que estaba habituado. Cuando he buscado alternativas, algunas de ellas sólo estaban para arquitectura i386. Mi gozo en un pozo.
  • Fallos menores:
    • Swiftfox no funciona del todo bien: No abre los ficheros descargados, pese a hacer doble click en ellos.
    • Unas veces en lugares me aparecen las tarjetas de memoria agrupadas agrupadas y otras no ¿por qué si siempre son las mismas?

Pequeños ajustes iniciales

Posted in configuración, linux, ubuntu by EdV on J mayo 2007

El sistema ya estaba funcionando de forma totalmente operativa, así que hice un par de ajustes:

  1. Activar el teclado numérico automaticamente. Para ello use numlockx, la instalación puede hacerse a través de Synaptic y de la consola (sudo apt-get install numlockx). Sin embargo esto no activa el teclado numérico en la pantalla de login, por lo que la contraseña mejor sin números (lo que no es lo más apropiado). Leí que también se podía activar, pero los procedimientos eran demasiado complejos.
  2. Inicio automático de la sesión, sin necesidad de introducir el usuario y la clave. En mi caso nadie más accede a mi ordenador (y menos a Ubuntu), y además tengo el problema de la resolución gigantesca, así que lo active siguiendo las indicaciones de Zootropo:

    Sistema -> Administración -> Ventana de entrada, en la pestaña seguridad marcamos “Activar entrada automática” y seleccionamos nuestro usuario del combo box inferior.

Configurando la resolución, la tasa de actualización (refresh rate) y los drivers de la tarjeta gráfica

Posted in configuración, gráficos, linux, problemas, ubuntu by EdV on J mayo 2007

Para instalar los drivers propietarios de nvidia creo que hice esto desde la consola:

sudo apt-get install nvidia-glx

Aunque también es posible hacerlo desde Synaptic (en mi caso no porque no podía inicar el modo gráfico)

El siguiente problema fue cambiar la resolución de pantalla. De manera automática no me permitía resoluciones que tanto la tarjeta como el monitor podían usar sin problemas. Este apartado fue y sigue siendo más complicado.

Busqué las especificaciones de mi monitor.

Usé un asistente (online modeline generator) para crear los datos necesarios que añadir a xorg.xonf

Por ejemplo deseo una resolución de 1280×1024 a 85 Hz. Introduzco estos datos y me sale esto:


Horizontal Resolution: 1280
Vertical Resolution: 1024
Vertical Refresh Rate: 85.00
HzHorizontal Refresh Rate: 91.72 KHz
Dot Clock Frequence: 185.64 MHz

# V-freq: 85.00 Hz // h-freq: 91.72 KHz
Modeline "1280x1024" 185.64 1280 1376 1600 2024 1024 1024 1028 1079

Copio las 2 últimas líneas y las añado a la sección “monitor” de xorg.conf


Section "Monitor"
Identifier "AOC HT731"
Option "DPMS"
Horizsync 30-98
Vertrefresh 50-160

# V-freq: 85.00 Hz // h-freq: 91.72 KHz
Modeline "1280x1024_85" 185.64 1280 1376 1600 2024 1024 1024 1028 1079# V-freq: 85.00 Hz // h-freq: 77.39 KHz

# V-freq: 85.00 Hz // h-freq: 77.39 KHz
Modeline "1152x864_85" 129.39 1152 1216 1376 1672 864 864 867 910

EndSection

En el ejemplo anterior he añadido otro modeline, en concreto para una resolución de 1152×864 a 85Hz. En negrita he destacado lo que he modificado o añadido:

  • Identifier: He escrito el modelo de mi monitor “AOC HT731”
  • Horizsync y vertrefresh: he añadido los valores del monitor según sus especificaciones.
  • Finalmente he añadido los modelines generados .

Cada uno de estos modeline tiene una denominación que es lo que aparece entrecomillado: “1152x864_85” y “1280x1024_85”. Esto es importante porque tendremos que usar estos nombres, junto con el del monitor, en la sección Screen:

Section "Screen"
Identifier "Default Screen"
Device "Tarjeta de vídeo genérica"
Monitor "AOC HT731"
Defaultdepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "800x600" "640x480" "1024x768" "1152x864_85" "1280x1024_85"
EndSubSection
EndSection

En negrita he marcado los aspectos a tener en cuenta: El nombre del monitor (porque lo había cambiado y tienen que coincidir) y los nombres de mis resoluciones personalizadas (los modlines generados). Solo los he añadido en la subsección de 24bits de profundidad porque es la que uso normalmente.

Hecho esto, reinicio el motor gráfico (reiniciando la sesión, aunque creo que hay otro modo), y elijo la resolución nueva que desee desde Sistema > Preferencias > resolución de pantalla. Se acabó, mi sobrio escritorio, por ahora:

Problemas:

Aunque la resolución del escritorio sea la correcta, la de la pantalla de identificación (login) es mucho más grande, de manera que solo se ve una porción de esta. Hay varios casos similares en los foros de ubuntu, pero aún no he encontrado una solución para mi caso (proponen quitar las resoluciones de mayor tamaño, pero ¿qué sucede cuando usas esa resolución?). Seguiré atento.

La instalación

Posted in instalaciones, linux, problemas, ubuntu by EdV on J mayo 2007

Mi instalación lleva unos cuantos días funcionando. Me bajé la versión para 64bits de Ubuntu. Nunca he conseguido que en el modo livecd me funcioné la tarjeta gráfica a la primera, incluso en modo seguro (Salen unas rayas verticales . Tuve que instalar los drivers de nvidia desde la línea de comandos (o como se llame); una vez hecho pude acceder al procedimiento gráfico de instalación. Aquí no hubo problemas porque ya tenía las particiones hechas de la instalación anterior de Ubuntu.

Un problema que también tenía en las v.6.06 y la 6.10 era que la conexión a internet no funcionaba. Tenía que entrar en las propiedades de red, deshabilitar la tarjeta ethernet, y volver a habilitar para que funcionase. En los foros de Ubuntu había varios casos como el mío, pero nunca encontré soluciones. Con 7.04 no he tenido ningún tipo de problemas en este sentido.

Después instalé Automatix2 y con él algunos programas más. Con el rollo de que no hay reproductor flash para 64bits tuve que usar swiftfox, que va bastante bien.

En cuanto recuerde los siguientes pasos que di, actualizo.